Valliant ecotec 837 - Doesn't heat up the radiators fully!

Questions about central heating and boiler questions in here please.

Moderator: Moderators

Post Reply
diy321
Newly registered Member
Posts: 16
Joined: Wed Aug 06, 2014 10:03 am
Has thanked: 5 times
Been thanked: 0

Valliant ecotec 837 - Doesn't heat up the radiators fully!

Post by diy321 » Thu Nov 22, 2018 11:48 pm

Hi,

Please can someone help me as I have a problem with my valliant ecotec 837. The boiler heats up the hot water perfectly fine, however the radiators don't heat up as they should do.

Please can someone advise what steps I can take to rectify this issue or at least help make a correct diagnose to assist with a potential solution?

Thanks in advance,

Bob
User avatar
someone-else
Senior Member
Posts: 8879
Joined: Sat Sep 01, 2012 6:03 pm
Has thanked: 32 times
Been thanked: 1498 times

Re: Valliant ecotec 837 - Doesn't heat up the radiators full

Post by someone-else » Thu Nov 22, 2018 11:59 pm

(I am NOT a plumber or heating engineer) Have you bled them? is one particular area of the rads cold?
Fret not, a forum is a collection of opinions. Above, are mine.

Which is correct? Metre or Meter? Click the link to find out more.

Working on anything electrical? have you got a multi meter? why not? Would you hit a nail with a shoe?

If gloom had a voice, it would be me. :mrgreen:

:idea1: How to post a picture on this forum Click here
diy321
Newly registered Member
Posts: 16
Joined: Wed Aug 06, 2014 10:03 am
Has thanked: 5 times
Been thanked: 0

Re: Valliant ecotec 837 - Doesn't heat up the radiators full

Post by diy321 » Fri Nov 23, 2018 12:17 am

By bleeding them you mean to check they are full of water rather than air? I believe the rads are full of water, just don't seem to heat up to fully, so all the rads are heating up at low temperature and essential the house just feels cold still.
User avatar
someone-else
Senior Member
Posts: 8879
Joined: Sat Sep 01, 2012 6:03 pm
Has thanked: 32 times
Been thanked: 1498 times

Re: Valliant ecotec 837 - Doesn't heat up the radiators full

Post by someone-else » Fri Nov 23, 2018 5:32 am

Yes, that is what I mean, but the question is, have you actually bled them? (Its worth a try)
Fret not, a forum is a collection of opinions. Above, are mine.

Which is correct? Metre or Meter? Click the link to find out more.

Working on anything electrical? have you got a multi meter? why not? Would you hit a nail with a shoe?

If gloom had a voice, it would be me. :mrgreen:

:idea1: How to post a picture on this forum Click here
diy321
Newly registered Member
Posts: 16
Joined: Wed Aug 06, 2014 10:03 am
Has thanked: 5 times
Been thanked: 0

Re: Valliant ecotec 837 - Doesn't heat up the radiators full

Post by diy321 » Tue Feb 05, 2019 7:11 am

Thanks for the advice, the temperature knob was damaged, this was replaced and all working now!
Post Reply

Return to “Central Heating & Boilers”