Problem with Hitachi NR90GC2 nail gun

All tool questions and recommendations or complaints in this forum please

Moderator: Moderators

Post Reply
Al_Bundy99
Newly registered Member
Posts: 2
Joined: Tue Oct 16, 2018 10:29 pm
Has thanked: 0
Been thanked: 0

Problem with Hitachi NR90GC2 nail gun

Post by Al_Bundy99 » Tue Oct 16, 2018 10:42 pm

Good evening I recently purchased a Hitachi NR90GC2 nail gun. On arrival I read the manual, charged the batteries, loaded the gas and nails that came with the tool. Pressed the tip against a test piece of wood and nothing happened. The fan never started and it obviously then wouldn't fire any nails. I swapped batteries and gas and still nothing. Eventually I sent it back and it must have been faulty as the retailer sent it back to Hitachi for repair. After a could of weeks a brand new gun arrived. I went through the same process of charging the batteries etc again and once again the fans never start and it will not fire any nails. The led on the tool flashes green to indicate the battery is charged but never goes solid. I've changed batteries, left then charging for hours, tried different strips of nails and different gas canisters etc but nothing seems to get it running. So this one seems to also be dead. Am I missing something or an I just unlucky to have another faulty tool?

Sent from my P027 using Tapatalk
fin
Senior Member
Posts: 6808
Joined: Wed Apr 16, 2008 6:49 pm
Location: south tyneside
Has thanked: 30 times
Been thanked: 522 times

Re: Problem with Hitachi NR90GC2 nail gun

Post by fin » Wed Oct 17, 2018 5:04 pm

theres not something stoping the tip being pressed fully in is there? like a piece of packaging or something
Al_Bundy99
Newly registered Member
Posts: 2
Joined: Tue Oct 16, 2018 10:29 pm
Has thanked: 0
Been thanked: 0

Re: Problem with Hitachi NR90GC2 nail gun

Post by Al_Bundy99 » Wed Oct 17, 2018 5:39 pm

Hi fin, The tip does depress but it is only a few millimeters. I've just had another look, to check if something is stopping the top depressing as you have suggested and it's something to do with the mechanism that stops the nails falling out the magazine. The manual says to load the nails and pull the nail feeder back. When I do that there's a bar that lowers and then the tip will depress by a cm or so and the gun will fire. For some reason the nail feeder isn't sitting at the end of the nail strip but travels all the way back up to the top and so the lever never lowers hence the gun is locked. Just got to figure out why that is. The nails and gas came with the gun so I assume they are compatible but it seems the feeder isn't catching. Thank you for the suggestion I'll do some more investigation.
fin
Senior Member
Posts: 6808
Joined: Wed Apr 16, 2008 6:49 pm
Location: south tyneside
Has thanked: 30 times
Been thanked: 522 times

Re: Problem with Hitachi NR90GC2 nail gun

Post by fin » Wed Oct 17, 2018 7:46 pm

my dewalt gun i have to pull the feeder back, then drop the nails in and then release it.

on my makita gun i just drop the nails in and then pull back the feeder.

maybe its the way that your doing it. coz there will be a stop so that the firing pin doesnt bash the nail feed mechanism.
Post Reply

Return to “Tool Talk”