Glow worm 15hxi: no flame with HW

Questions about central heating and boiler questions in here please.

Moderator: Moderators

Post Reply
mauroercolini
Newly registered Member
Posts: 4
Joined: Sat Jan 09, 2021 4:19 pm
Has thanked: 1 time
Been thanked: 0

Glow worm 15hxi: no flame with HW

Post by mauroercolini »

Hi all, new to the forum. So I have this Glow worm 15hxi with a smart wiring centre 2. A few months back it started behaving strangely. CH was fine. But when HW was needed the pump would kick in but no flame, which would eventually make all water in the tank cold. Even if the CH was on, and so the flame was on, if then HW kicked in that would kill the flame instantly.

A plumber came and decided the smart wiring needed changing. And everything went back to normal. But now it's doing the same thing again. I cannot believe the wiring centre went again. I'm writing here hoping that something easy like a reset or reprogram might fix it. any thoughts?

thank you very much
Mauro
User avatar
aeromech3
Senior Member
Posts: 2161
Joined: Fri Feb 26, 2010 11:16 am
Location: Ash Surrey
Has thanked: 114 times
Been thanked: 357 times

Glow worm 15hxi: no flame with HW

Post by aeromech3 »

:welcomeuhm: Well an expert should comment but from what you have described:- your boiler does not have a data e-bus 24v connection so I am puzzled as to the use of a smart wiring centre 2; your boiler should only get a switched 240v supply to fire and from boiler wiring the pump should get its supply ( ignoring the permanent supply for pump overrun) ; sounds as if your pump is getting a supply from elsewhere than the boiler HW call switched live is missing, either due a valve or cylinder stat problem But that does not relate to the HW killing the valid CH call to the boiler.
Please advise your layout, do you have a vented or sealed tank? Do you have one three way valve (3 pipes attached) or two zone valves (2 pipes to each) ? What programmer do you have to control times and room temperature?
mauroercolini
Newly registered Member
Posts: 4
Joined: Sat Jan 09, 2021 4:19 pm
Has thanked: 1 time
Been thanked: 0

Glow worm 15hxi: no flame with HW

Post by mauroercolini »

aeromech3 wrote:
Tue Jan 12, 2021 6:09 pm
:welcomeuhm: Well an expert should comment but from what you have described:- your boiler does not have a data e-bus 24v connection so I am puzzled as to the use of a smart wiring centre 2; your boiler should only get a switched 240v supply to fire and from boiler wiring the pump should get its supply ( ignoring the permanent supply for pump overrun) ; sounds as if your pump is getting a supply from elsewhere than the boiler HW call switched live is missing, either due a valve or cylinder stat problem But that does not relate to the HW killing the valid CH call to the boiler.
Please advise your layout, do you have a vented or sealed tank? Do you have one three way valve (3 pipes attached) or two zone valves (2 pipes to each) ? What programmer do you have to control times and room temperature?
Hi Aeromech3, thank you for your answer. I'm not sure about vented or sealed. How can I tell? I had a read on internet and if I understand correctly vented tanks have an expansion cistern, then I do have one in the loft. I have a 3 way valve. I have a climapro2 RF as a programmer, which I guess answers your question as to why they used the smart wiring centre. I don't think the boiler can handle a wireless thermostat on its own. But I'm only speculating, as I'm no expert and this system came with the house. I'm personally considering bypassing the lot and putting an old fashioned programmer/thermostat.

Thank you very much for your help
User avatar
aeromech3
Senior Member
Posts: 2161
Joined: Fri Feb 26, 2010 11:16 am
Location: Ash Surrey
Has thanked: 114 times
Been thanked: 357 times

Glow worm 15hxi: no flame with HW

Post by aeromech3 »

Interesting, if your loft expansion tank is still active (some leave them up there when upgrading to combi) then you have a vented system and namely a Y plan. The climpro2 RF talks to the smart centre 2 but is the boiler an Ultracom which does have a data link? If so it is beyond my experience level.
These users thanked the author aeromech3 for the post:
mauroercolini (Mon Jan 18, 2021 6:31 pm)
Rating: 7.14%
mauroercolini
Newly registered Member
Posts: 4
Joined: Sat Jan 09, 2021 4:19 pm
Has thanked: 1 time
Been thanked: 0

Glow worm 15hxi: no flame with HW

Post by mauroercolini »

Hi Aeromech3, thank you for trying
mauroercolini
Newly registered Member
Posts: 4
Joined: Sat Jan 09, 2021 4:19 pm
Has thanked: 1 time
Been thanked: 0

Glow worm 15hxi: no flame with HW

Post by mauroercolini »

UPDATE: I've reset the boiler and everything works now. In case it helps anyone
Post Reply

Return to “Central Heating & Boilers”