DIY Forum

 

Ultimate Handyman Ultimate Handyman Ultimate Handyman Ultimate HandymanUltimate Handyman on Pinterest

 

DIY Forum/Home improvement advice forum

 

 

A-Z CONTENTS | DISCLAIMER | DIY VIDEO | HOME | SAFETY FIRST | FORUM RULES

It is currently Sat Nov 18, 2017 2:04 pm
Visit Thermo worx


Time zone: Europe/London




 

 


Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Oct 22, 2017 10:33 am 
Offline
Newly registered Member

Joined: Mon May 07, 2012 4:19 pm
Posts: 4
Has thanked: 0 times
Been thanked: 0 times
Boiler shuts itself after a minute Biasi Riva Compact he mk2 m96a.28sm/c

I tried resetting the boiler. The boiler starts when I open the hot water tap/CH.

1. fan starts spinning.
2. Boiler fires Up.
3. pressure gauge flickers and then goes up to 3.5 and drops below 1.
4. The boiler locks out
5. water is thrown out of the overflow pipe to the garden.

The trouble shooting LED are all over the place after every reset. I

I saw the following combinations LEDs (1 Green,2 Red,3 Green) starting from left

1. Lit , Lit, Flashing - Flue temperature probe NTC lock out.
2. (1 and 2 alternates) Flash, Lit , OFF - Faulty primary circuit (absence of flow) When this was showing the pump made loud knocks before the shutdown.
3. Lit, Flash, Flash - Safety thermostat lock out.


I have home insurance cover for certain amount and an engineer was called in this morning. He thinks its a faulty pump, but nothing could be done today as it is Sunday today. I have a feeling its not the pump as I can feel the motor spin and I did a bleeding and with the screwdriver I tried spinning the motor and it moves freely.

Any thoughts? Thanks in advance.


Share on FacebookShare on TwitterShare on DiggShare on DeliciousShare on Google+
Top
 Profile  
Reply with quote  
PostPosted: Sun Oct 22, 2017 11:33 am 
Offline
Senior Member

Joined: Mon Apr 13, 2009 8:03 pm
Posts: 6303
Has thanked: 723 times
Been thanked: 762 times
Possibly the pump, but from my experience usually the plate heat exchanger or main heat exchanger blocked with sludge.

Does it work for the heating?

It definitely has no flow and is overheating for some reason, hence the numerous fault codes.

_________________
Dave

www.drlgas.co.uk



For this message the author gas4you has received gratitude : multiman
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 


Similar topics
   

Time zone: Europe/London


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Visit Hilti


 

 

 

News News Site map Site map SitemapIndex SitemapIndex RSS Feed RSS Feed Channel list Channel list
ultimatehandyman privacy policy

Contact

 

Powered by phpBB® Forum Software © phpBB Group

phpBB SEO